package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$`)
var str = `9999
5446
1
2
12
99
100
0
1234
9999
10000
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}