const regex = /^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$', 'gm')
const str = `9999
5446
1
2
12
99
100
0
1234
9999
10000
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);