re = /^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$/m
str = '9999
5446
1
2
12
99
100
0
1234
9999
10000
'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result