#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$"
Local $sString = "9999" & @CRLF & _
"5446" & @CRLF & _
"1" & @CRLF & _
"2" & @CRLF & _
"12" & @CRLF & _
"99" & @CRLF & _
"100" & @CRLF & _
"0" & @CRLF & _
"1234" & @CRLF & _
"9999" & @CRLF & _
"10000" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)