import re
regex = re.compile(r"^(?:[1-9][0-9]{3}|[1-9][0-9]{2}|[1-9][0-9]|[1-9])$", flags=re.MULTILINE)
test_str = ("9999\n"
"5446\n"
"1\n"
"2\n"
"12\n"
"99\n"
"100\n"
"0\n"
"1234\n"
"9999\n"
"10000\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)