#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\/])"
Local $sString = ""../img/hero/layer4.png" & @CRLF & _
""../images/bg-top.jpg" & @CRLF & _
"'img/logo.jpg" & @CRLF & _
"'img/btn/banner-submit.jpg" & @CRLF & _
""img/btn/animated-thank-you-banner.gif" & @CRLF & _
"" & @CRLF & _
"<img src="img/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")