$re = '/(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\\\/])/';
$str = '"../img/hero/layer4.png
"../images/bg-top.jpg
\'img/logo.jpg
\'img/btn/banner-submit.jpg
"img/btn/animated-thank-you-banner.gif
<img src="img/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);