use strict;
my $str = '"../img/hero/layer4.png
"../images/bg-top.jpg
\'img/logo.jpg
\'img/btn/banner-submit.jpg
"img/btn/animated-thank-you-banner.gif
<img src="img/';
my $regex = qr/(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\/])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}