using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\/])";
string input = @"""../img/hero/layer4.png
""../images/bg-top.jpg
'img/logo.jpg
'img/btn/banner-submit.jpg
""img/btn/animated-thank-you-banner.gif
<img src=""img/";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}