re = /(?:(\.\.\/)|)(img|imgs|image|images)(.*[\\\/])/
str = '"../img/hero/layer4.png
"../images/bg-top.jpg
\'img/logo.jpg
\'img/btn/banner-submit.jpg
"img/btn/animated-thank-you-banner.gif
<img src="img/'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end