#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)"
Local $sString = "## case_id 821652" & @CRLF & _
"AP CCP" & @CRLF & _
"Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |" & @CRLF & _
"" & @CRLF & _
"## case_id 862568" & @CRLF & _
"AP CCP" & @CRLF & _
"Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no | " & @CRLF & _
"" & @CRLF & _
"internal complaint from CSR" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")