$re = '/^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)/m';
$str = '## case_id 821652
AP CCP
Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |
## case_id 862568
AP CCP
Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no |
internal complaint from CSR
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);