const regex = /^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^AP CCP\\b(?:.|\\n)*?URL(?:\\(s\\))?:\\s*([^\\|(]*)', 'gm')
const str = `## case_id 821652
AP CCP
Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |
## case_id 862568
AP CCP
Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no |
internal complaint from CSR
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}