package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)`)
var str = `## case_id 821652
AP CCP
Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |
## case_id 862568
AP CCP
Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no |
internal complaint from CSR
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}