// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)").unwrap();
let string = "## case_id 821652
AP CCP
Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |
## case_id 862568
AP CCP
Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no |
internal complaint from CSR
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}