import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^AP CCP\\b(?:.|\\n)*?URL(?:\\(s\\))?:\\s*([^\\|(]*)";
final String string = "## case_id 821652\n"
+ "AP CCP\n"
+ "Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |\n\n"
+ "## case_id 862568\n"
+ "AP CCP\n"
+ "Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no | \n\n"
+ "internal complaint from CSR\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}