import re
regex = re.compile(r"^AP CCP\b(?:.|\n)*?URL(?:\(s\))?:\s*([^\|(]*)", flags=re.MULTILINE)
test_str = ("## case_id 821652\n"
"AP CCP\n"
"Brand: NFL | URL(s): comejerseys.top, ourjerseys.top (both sites already disabled in Valhalla) | CID(s): | BrandOwner: no |\n\n"
"## case_id 862568\n"
"AP CCP\n"
"Brand: Kaspersky | URL(s):kasperskyguide.com/ | CID(s): | BrandOwner: no | \n\n"
"internal complaint from CSR\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")