#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)"
Local $sString = "@Don't replace this line: <http://nomatch.com#>" & @CRLF & _
"/or this line!/" & @CRLF & _
"" & @CRLF & _
"<http://example.com#Example/Replace/With/Underscores>" & @CRLF & _
"<http://example.com#Example/Can/Have/Trailing/Slash/>" & @CRLF & _
"" & @CRLF & _
"</Nothing to replace on this line either./>"
Local $sSubst = "_"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)