# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)"
test_str = ("@Don't replace this line: <http://nomatch.com#>\n"
"/or this line!/\n\n"
"<http://example.com#Example/Replace/With/Underscores>\n"
"<http://example.com#Example/Can/Have/Trailing/Slash/>\n\n"
"</Nothing to replace on this line either./>")
subst = "_"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.