use strict;
my $str = '@Don\'t replace this line: <http://nomatch.com#>
/or this line!/
<http://example.com#Example/Replace/With/Underscores>
<http://example.com#Example/Can/Have/Trailing/Slash/>
</Nothing to replace on this line either./>';
my $regex = qr/(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)/mp;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";