const regex = /(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<http:\\\/\\\/example\\.com#Example\\\/[^>]*)\\\/(?=[^>]*>)', 'gm')
const str = `@Don't replace this line: <http://nomatch.com#>
/or this line!/
<http://example.com#Example/Replace/With/Underscores>
<http://example.com#Example/Can/Have/Trailing/Slash/>
</Nothing to replace on this line either./>`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);