import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<http:\\/\\/example\\.com#Example\\/[^>]*)\\/(?=[^>]*>)";
final String string = "@Don't replace this line: <http://nomatch.com#>\n"
+ "/or this line!/\n\n"
+ "<http://example.com#Example/Replace/With/Underscores>\n"
+ "<http://example.com#Example/Can/Have/Trailing/Slash/>\n\n"
+ "</Nothing to replace on this line either./>";
final String subst = "_";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}