using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)";
string substitution = @"_";
string input = @"@Don't replace this line: <http://nomatch.com#>
/or this line!/
<http://example.com#Example/Replace/With/Underscores>
<http://example.com#Example/Can/Have/Trailing/Slash/>
</Nothing to replace on this line either./>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}