$re = '/(?<=<http:\/\/example\.com#Example\/[^>]*)\/(?=[^>]*>)/m';
$str = '@Don\'t replace this line: <http://nomatch.com#>
/or this line!/
<http://example.com#Example/Replace/With/Underscores>
<http://example.com#Example/Can/Have/Trailing/Slash/>
</Nothing to replace on this line either./>';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;