#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?miu)(\b\d{1,2}/) +(\d{1,2})(?=/\d{4}\b)"
Local $sString = "11/ 1/2015" & @CRLF & _
"12/ 12/2015" & @CRLF & _
"1/ 1/2015"
Local $sSubst = "\1\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)