using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\b\d{1,2}/) +(\d{1,2})(?=/\d{4}\b)";
string substitution = @"\1\2";
string input = @"11/ 1/2015
12/ 12/2015
1/ 1/2015";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase | RegexOptions.CultureInvariant;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}