$re = '~(\b\d{1,2}/) +(\d{1,2})(?=/\d{4}\b)~miu';
$str = '11/ 1/2015
12/ 12/2015
1/ 1/2015';
$subst = "\1\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;