re = /(\b\d{1,2}\/) +(\d{1,2})(?=\/\d{4}\b)/mi
str = '11/ 1/2015
12/ 12/2015
1/ 1/2015'
subst = '\\1\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result