import re
regex = re.compile(r"(\b\d{1,2}/) +(\d{1,2})(?=/\d{4}\b)", flags=re.MULTILINE | re.IGNORECASE | re.UNICODE)
test_str = ("11/ 1/2015\n"
"12/ 12/2015\n"
"1/ 1/2015")
subst = "\\1\\2"
result = regex.sub(subst, test_str)
if result:
print(result)