# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^\(?\+?[\(\)\- 0-9]{8,20}$//;t' <<< "(+56)=1 23 467 890"