const regex = /^\(?\+?[\(\)\- 0-9]{8,20}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\(?\\+?[\\(\\)\\- 0-9]{8,20}$', '')
const str = `(+56)=1 23 467 890`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);