$re = '/^\(?\+?[\(\)\- 0-9]{8,20}$/';
$str = '(+56)=1 23 467 890';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;