import re
regex = re.compile(r"^\(?\+?[\(\)\- 0-9]{8,20}$")
test_str = "(+56)=1 23 467 890"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)