use strict;
my $str = '(+56)=1 23 467 890';
my $regex = qr/^\(?\+?[\(\)\- 0-9]{8,20}$/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";