# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/Size:\s+([A-Z0-9-]+),/$1/gm;t' <<< "Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,"