#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)Size:\s+([A-Z0-9-]+),"
Local $sString = "Size: XS-S-M-L-XL-2XL," & @CRLF & _
"Size: XS-S-M,"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)