using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Size:\s+([A-Z0-9-]+),";
string substitution = @"$1";
string input = @"Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}