// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)Size:\s+([A-Z0-9-]+),").unwrap();
let string = "Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}