use strict;
my $str = 'Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,';
my $regex = qr/Size:\s+([A-Z0-9-]+),/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";