re = /Size:\s+([A-Z0-9-]+),/m
str = 'Size: XS-S-M-L-XL-2XL,
Size: XS-S-M,'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result