import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w._-]+@[\\w.-]+\\.[a-z]{2,4}(\\.[a-z]{2,3})?";
final String string = "viel text mein@domain.or.at viel text viel text \n"
+ "viel text mein.name@domain.at viel text viel text \n"
+ "viel text mein-name@domain.at viel text viel text \n"
+ "viel text mein_name@domain.at viel text viel text \n"
+ "viel text mein_name@domain-domain.at viel text viel text \n"
+ "viel text me1n_name@domain-domain.at viel text viel text \n"
+ "viel text me1n_name@domain-domain.wien viel text viel text \n\n"
+ "viel text mein.name@domain.or.at viel text viel text \n"
+ "viel text mein-name@domain.or.at viel text viel text \n"
+ "viel text mein_name@domain.or.at viel text viel text \n"
+ "viel text mein_name@domain-domain.or.at viel text viel text\n"
+ "viel text me1n_name@doma1n-doma1n.or.at viel text viel text\n"
+ "viel text me1n_name@doma1n-doma1n.wien viel text viel text\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}