import re
regex = re.compile(r"[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?")
test_str = ("viel text mein@domain.or.at viel text viel text \n"
"viel text mein.name@domain.at viel text viel text \n"
"viel text mein-name@domain.at viel text viel text \n"
"viel text mein_name@domain.at viel text viel text \n"
"viel text mein_name@domain-domain.at viel text viel text \n"
"viel text me1n_name@domain-domain.at viel text viel text \n"
"viel text me1n_name@domain-domain.wien viel text viel text \n\n"
"viel text mein.name@domain.or.at viel text viel text \n"
"viel text mein-name@domain.or.at viel text viel text \n"
"viel text mein_name@domain.or.at viel text viel text \n"
"viel text mein_name@domain-domain.or.at viel text viel text\n"
"viel text me1n_name@doma1n-doma1n.or.at viel text viel text\n"
"viel text me1n_name@doma1n-doma1n.wien viel text viel text\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")