// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?").unwrap();
let string = "viel text mein@domain.or.at viel text viel text
viel text mein.name@domain.at viel text viel text
viel text mein-name@domain.at viel text viel text
viel text mein_name@domain.at viel text viel text
viel text mein_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.wien viel text viel text
viel text mein.name@domain.or.at viel text viel text
viel text mein-name@domain.or.at viel text viel text
viel text mein_name@domain.or.at viel text viel text
viel text mein_name@domain-domain.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.wien viel text viel text
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}