re = /[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?/
str = 'viel text mein@domain.or.at viel text viel text
viel text mein.name@domain.at viel text viel text
viel text mein-name@domain.at viel text viel text
viel text mein_name@domain.at viel text viel text
viel text mein_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.wien viel text viel text
viel text mein.name@domain.or.at viel text viel text
viel text mein-name@domain.or.at viel text viel text
viel text mein_name@domain.or.at viel text viel text
viel text mein_name@domain-domain.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.wien viel text viel text
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end