use strict;
my $str = 'viel text mein@domain.or.at viel text viel text
viel text mein.name@domain.at viel text viel text
viel text mein-name@domain.at viel text viel text
viel text mein_name@domain.at viel text viel text
viel text mein_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.wien viel text viel text
viel text mein.name@domain.or.at viel text viel text
viel text mein-name@domain.or.at viel text viel text
viel text mein_name@domain.or.at viel text viel text
viel text mein_name@domain-domain.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.wien viel text viel text
';
my $regex = qr/[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}