const regex = /[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w._-]+@[\\w.-]+\\.[a-z]{2,4}(\\.[a-z]{2,3})?', '')
const str = `viel text mein@domain.or.at viel text viel text
viel text mein.name@domain.at viel text viel text
viel text mein-name@domain.at viel text viel text
viel text mein_name@domain.at viel text viel text
viel text mein_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.wien viel text viel text
viel text mein.name@domain.or.at viel text viel text
viel text mein-name@domain.or.at viel text viel text
viel text mein_name@domain.or.at viel text viel text
viel text mein_name@domain-domain.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.wien viel text viel text
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}