import Foundation
let pattern = #"[\w._-]+@[\w.-]+\.[a-z]{2,4}(\.[a-z]{2,3})?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
viel text mein@domain.or.at viel text viel text
viel text mein.name@domain.at viel text viel text
viel text mein-name@domain.at viel text viel text
viel text mein_name@domain.at viel text viel text
viel text mein_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.at viel text viel text
viel text me1n_name@domain-domain.wien viel text viel text
viel text mein.name@domain.or.at viel text viel text
viel text mein-name@domain.or.at viel text viel text
viel text mein_name@domain.or.at viel text viel text
viel text mein_name@domain-domain.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.or.at viel text viel text
viel text me1n_name@doma1n-doma1n.wien viel text viel text
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}