#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"([^"]+.jpg)""
Local $sString = "<a href="/index.html">Home</a>" & @CRLF & _
"<a href="xmas-greeting-dolly.jpg">xmas-greeting-dolly.jpg</a>" & @CRLF & _
"<a href="privacy.html"><font color="#003366">View WavList.com 's Privacy Policy</font></a>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")