re = /"([^"]+.jpg)"/m
str = '<a href="/index.html">Home</a>
<a href="xmas-greeting-dolly.jpg">xmas-greeting-dolly.jpg</a>
<a href="privacy.html"><font color="#003366">View WavList.com \'s Privacy Policy</font></a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end