use strict;
my $str = '<a href="/index.html">Home</a>
<a href="xmas-greeting-dolly.jpg">xmas-greeting-dolly.jpg</a>
<a href="privacy.html"><font color="#003366">View WavList.com \'s Privacy Policy</font></a>';
my $regex = qr/"([^"]+.jpg)"/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}